[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: change in behavior of iptables with respect to firestarter



On 10/22/2010 08:18 PM, Rob Owens wrote:
On Fri, Oct 22, 2010 at 06:48:34PM -0400, Gilbert Sullivan wrote:

There is an /etc/init.d/firestarter file and an
/etc/firestarter/configuration file (that later one being present in its
directory with a whole bunch of other files.).

After a fresh reboot, with firestarter not running, what happens if you
run:

/etc/init.d/firestarter start

That's what should be running during bootup.  Maybe it'll show you some
error messages if you run it from a terminal after bootup.

-Rob

As root I ran

/etc/init.d/firestarter start

and I got

Starting the Firestarter firewall....

I ran

iptables -L

and I could see that iptables is properly doing "its thing". The rules are in place!

So, for some reason, firestarter isn't being started during the boot process.

So, I guess I have to find out whether the fact that firestarter isn't being started is because a) it hasn't been asked to start, or b) it has been asked to start, but with insufficient credentials (or, in some other manor, improperly). Have I got that right?

Since I'm not seeing any error messages in logs, I'm guessing that it hasn't been asked to start -- for some reason.

I'm horribly tired, and I've got to get some sleep. I'm going to try to look at this with fresh eyes tomorrow.

Thank you so much for continuing to work with me on this.

Regards,
Gilbert


Reply to: