[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Continue without install grub (y/n) confusion



On Tue, Oct 19, 2010 at 7:42 PM, Tom H <tomh0665@gmail.com> wrote:
> On Tue, Oct 19, 2010 at 12:30 PM, Boyd Stephen Smith Jr.
> <bss@iguanasuicide.net> wrote:
>> In <AANLkTikgo1DmfxjA=nsLJ1CMxbwcER4c1nwqG7xm-Kbf@mail.gmail.com>, Tom H
>> wrote:
>>>"/boot" can only be on raid1 because the bootloaders need to access
>>>before mdadm assembles the array and, with raid1, the bootloaders can
>>>access one of the submirrors.
>>
>> I thought Grub2 was going to be able to handle (at least) RAID 5.  In theory,
>> grub2 should be able to support all raid layouts that mdadm does, but it would
>> require someone porting the relevant code from kernel-space to bootloader-
>> space.
>
> That's what I thought last December and I tried with raid5 but
> couldn't get it to work.
>
> You've now motivated me to try again...

Sorry, I mispoke. I must have made some mistake/mistakes last December
or grub2 wasn't up to the task yet.

I've tried installing Squeeze in a VBox with one partition (just "/"
and no swap) with 3-disk raid5, 4-disk raid6, and 6-disk raid6.

The 6-disk failed; I was dumped to the grub rescue prompt and couldn't
go further because I could only list the raid device and four of the
six disks with "ls"... I have no idea whether it is a VBox limitation
or a grub one; I think that it must be VBox but it's just a more or
less educated guess.

The other two booted up OK.

Going back to the OP, are you using partitioned arrays? (If, yes, FYI
I've tried twice to install grub2 on that type of device and failed;
it could be a PEBKAC though...).


Reply to: