[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOT] Installing additional Wesnoth campaigns

On 03/10/10 09:58, tv.debian@googlemail.com wrote:
Le 03/10/2010 00:22, AG a écrit :
On 02/10/10 22:54, tv.debian@googlemail.com wrote:
Le 02/10/2010 20:51, AG wrote:

On 06/09/09 17:33, thveillon.debian wrote:

AG wrote:


Sorry if this is too far OT, but I was hoping for some Debian-specific
advice on obtaining and using Battle for Wesnoth campaigns.  The
website/ forum provides some linkages to additional campaigns, but
following their instructions I just can't seem to call the supposedly
installed Wesnoth files.

Has anyone had any success in this, and if so, care to share the trick

Cheers verily.


Good question about Sunday mission-critical apps ;-)

Read about the user made campaigns here:


(this is for wesnoth 1.6, pick the right one for you, i.e. 1.7 is in

Download add-ons (campaigns but not only) from:


(again for 1.6)

Unpack the archives, copy the whole campaign folder into:


(this is for full campaigns, for other add-ons you'll have to look

(Re)start wesnoth, the new campaigns should be available from the
campaigns selector.

Remember to look at the campaign development status, if it's rated
(Work In Progress) or "broken", you'll likely be disappointed as a
player, or thrilled as custom campaign developer...


Hi again

I've just tried this again with version 1.8 However, the new campaigns
don't appear in the Campaigns menu of Wesnoth 1.8.  I've changed
permissions and chown and chgrp, but still no dice.

Am I overlooking something?



Hi, just made a quick test here downloading a campaign from
http://www.wesnoth.org/addons/1.8/ and copied it to
~/.wesnoth1.8/data/add-ons , it works fine.

Permissions are drwxr-x--- all the way down to the "add-ons" files.

I am talking about wesnoth 1.8.3-5 from Sid on a mostly Squeeze AMD64

Hmmm ... that's interesting:  I have all of the untarred campaigns
loaded to /usr/share/games/wesnoth/data/campaigns.

All permissions are also drwxr -xr-x throughout the campaigns directory.

This is on testing x86.

I can't think of what else I need to be adjusting.  Any thoughts?


Hi, you should have a /usr/share/games/wesnoth/1.8/data/campaigns/
directory, that's where the campaigns should be if you want them
installed system-wide with wesnoth 1.8. Note the "1.8", I think that's
because two versions of wesnoth coexisted for a while in the archives.

Have fun.

Doh!! :-(

Thanks for pointing that out to me - it is a rather significant detail I omitted.

Everything is up and running: thanks again.


Reply to: