[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What is blocking my sound?

On 09/24/10 07:20, Marc Shapiro wrote:
On 09/23/10 18:42, T o n g wrote:
On Thu, 23 Sep 2010 18:11:09 -0700, Marc Shapiro wrote:

Usually the fix is to close all instances of Firefox until I find the
culprit, and sound returns.

The alternative to above headaches is use alsa as much as possible, not
oss! E.g.,

- use aplay instead of play.
- install libsox-fmt-alsa so that sox (ie play) uses alsa interface
instead of oss.


The last time I tried aplay, it did not work. I don't remember what the
problem was. If I simply use aplay to try and play the file I get the
same error. I will have to power down the machine and try it again when
I get a chance. No time this weekend.

I shut down all X sessions and was able to get my sound back. I then tried to play the file that I use to test my sound using aplay, instead of play, and got the following error:

	aplay: test_wavefile:749: can't play not PCM-coded WAVE-files

which somewhat rules out using aplay instead of play. Also, I checked to see if libsox-fmt-alsa was installed, and it already is:

Package: libsox-fmt-alsa
New: yes
State: installed
Automatically installed: yes
Version: 14.0.1-2+b1

does anyone have any other ideas. There must be some way of making flash play well with linux and other apps.


Reply to: