[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

XFS: xfs_repair never finishes on lvm partition


I'm using Debian Lenny box with 2 hds.

The first one is used by the OS and the second one is another system witch runs in virtual machine (Virtual Box).
This virtual machine also runs Debian Lenny.

The vm's hd has 2 fdisk partitions, one being LVM.

On the last week, due a power failure, there was a corruption in the file system of my home xfs partition inside the LVM.
When  I tried to access it, my OS answered that it's not a file or a directory.
Umounting and mounting again, the error persists.
I tried an xfs_check and it said to mount and umount the filesystem and if it does not work to run xfs_repair with -L.
I tried it a couple of times and it didn't work, so I ran xfs_repair -L /dev/mapper/storage-home

On Phase 6, it just freezes in:

bad hash table for directory inode 2147483859 (no data entry): rebuilding
rebuilding directory inode 2147483859

And never finish.
I let running for 2 days long.

When I use ps to see the state:

 2359 pts/0    Sl+    0:11 xfs_repair -L /dev/mapper/storage-home

Interruptible sleep (waiting for an event to complete), multi threaded, in foreground.

It just stoped when I sent an interrupt signal Ctrl+C.

I tried to do the same from the host machine (real machine), since the HD could be accessed from it.
The funniest thing is that the xfs_repair did not hang, but when I try to mount the partition it does not mount the  full partition.
An ls in the /mnt mounting /dev/storage/home (from host machine), doesn't show the /home, it shows a subdirectory from /home.
And if I start again the Virtual Machine, it prints the same error: /home is not file or directory.


Some one have any idea, how to solve it?

Thanks in advance




Reply to: