[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ps - Illegal Instruction

On 9/19/2010 8:23 PM, Timo Juhani Lindfors wrote:
Jerry Stuckle<jstuckle@attglobal.net>  writes:
I still have several problems, which may be related.  The easiest one
to find is an "Illegal Instruction" when I run a simple ps command.
This occurs whether I run as a user or root.

So gnome starts but ps fails? Very odd. Please

1) apt-get install debsums
2) debsums

to see if any files are corrupted.

Hi, Timo, and thanks for responding. Yes, gnome starts, although occasionally I get

debsums by itself found a LOT of good files, so I ran it with -s. The only mismatch it found was on


That shouldn't be a problem.

Rerunning with -a -s added a mismatch for


But I don't think that should be a problem, either.

Further testing indicates when I boot into the single user mode, ps works fine. Also, during normal boot I found an Illegal Instruction message for sysctl - which fails from a command line on normal boot also, but works in single user mode.

And as to the suggestions from other users to try another VM - that's not open for discussion unless you can tell my why the one that comes with Windows 7 doesn't work.


Reply to: