[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrade of squeeze hangs on apt (0.7.26~exp3)

With a brand new installation of squeeze, one of my first steps was to
do a package update and a safe-upgrade. The former went well, but when
I tried to upgrade the 22 updated packages, the upgrade proceedure
terminated with:

  Reading changelogs ... done

  apt (0.7.26~exp3) experimental; urgency=low
    * apt-ftparchive now reads the standard configuration files in
      /etc/apt/apt.conf and /etc/apt/apt.conf.d 

and after some more lines ends with 

  /tmp/tmpXXXX (END)

and it takes a Ctl-C to break back to a command prompt. The upgrade
process is terminated and nothing was actually upgraded. I can repeat,
and each time only the tmp file id number changes, but the 22 packages
are still not upgraded.

A google search leaves me unclear, but it seems that some experimental
features of apt are being merged into squeeze. 

Should I just ignore this until such time as a clean upgrade becomes
possible? Is there a work-around?

Haines Brown

Reply to: