[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Squeeze System "Bricked" after Software Upgrades 09/04

I have a Panasonic subnotebook (CF-R3) that has been functioning superbly for months under Squeeze with Xfce/gdm. It has an integrated Intel video system and a Japanese / English keyboard with which I have used the standard kernel mapping (chosen during Expert install). This is Squeeze with no proprietary firmware and the stock repositories (no third party repositories, no non-free, all software installations throughout the history of the system on this OS being made through aptitude).

This morning (09/04) after applying latest updates through aptitude, I rebooted the system. It hard locked after it started loading gdm. The REISUB key combination had no effect whatsoever on the system. I was unable to connect to it via Ethernet. I had to force it down with the power switch.

I can boot into recovery mode. I used "touch /forcefsck" to get a file system check during a reboot. No errors reported.

Below is the list of software upgrades applied this morning.

[UPGRADE] apt -> 0.8.0
[UPGRADE] apt-utils -> 0.8.0
[UPGRADE] aptitude 0.6.3-3 -> 0.6.3-3.1
[UPGRADE] aptitude-doc-en 0.6.3-3 -> 0.6.3-3.1
[UPGRADE] firmware-linux-free 2.6.32-20 -> 2.6.32-21
[UPGRADE] libept1 1.0.3 -> 1.0.3+b1
[UPGRADE] libldap-2.4-2 2.4.17-2.1 -> 2.4.23-4
[UPGRADE] libparted0debian1 2.3-1 -> 2.3-2
[UPGRADE] libsdl-gfx1.2-4 2.0.20-1 -> 2.0.20-1.1
[UPGRADE] linux-base 2.6.32-20 -> 2.6.32-21
[UPGRADE] linux-image-2.6.32-5-686 2.6.32-20 -> 2.6.32-21
[UPGRADE] python-apt ->
[UPGRADE] python-gobject 2.21.1-2 -> 2.21.4+is.2.21.3-1
[UPGRADE] python-xapian 1.0.20-1 -> 1.2.3-3
[UPGRADE] xserver-common 2:1.7.7-3 -> 2:1.7.7-4
[UPGRADE] xserver-xephyr 2:1.7.7-3 -> 2:1.7.7-4
[UPGRADE] xserver-xorg-core 2:1.7.7-3 -> 2:1.7.7-4

I have a very different notebook (Dell Precision M70) that has exactly the same installation history. (I run them side-by-side, relying upon the Panasonic system as an emergency backup if the Dell should fail.) No problems ever running Squeeze on these systems other than some minor issues in the Nouveau driver transition on the Dell system a couple of months ago.

I've tried examining dmesg output, /var/log/syslog, /var/log/Xorg.0.log -- but, if there is evidence in there of why this is happening I'm not seeing it. (I'm happy to admit that I've in well over my head on this, though.)

From the list of upgraded software I suppose that my problem is either with the linux-image upgrade or with the xserver upgrades. Unfortunately, I have no previous kernels from which to boot the system. It does not have an optical drive, but I can attach one to a USB port and boot another environment if need be. I have a feeling that this isn't a hardware issue, though.

Would someone be willing to lead me through troubleshooting? I'd really appreciate it!

Reply to: