[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No sound from Flash, but other methods work well

On 17/07/10 02:02 PM, Ron Johnson wrote:

My Google-fu must not be up to snuff, because I've Googled much without
any luck.

USB Audio
32-bit Sid
ALSA 1.0.23+dfsg-1
Flash 10.1r53 (from adobe.com)
Iceweasel 3.6.4-1 (experimental)
vlc 1.1.0
users are in group audio

Sound plays fine from local sources but not from Flash/Iceweasel. (Yes,
Flash *video* works.)

Happened with me too for the last couple of days. It started when I noticed that I could not redirect the output of flash videos from Pulseaudio. In fact, a playing flash video does not even register in Pulseaudio's Playback tab. So in trying to fix this, I started to try various things. One of which was to try flashplayer-mozilla. Well, that mucking around with the working flashplayer ended up in killing its audio.

Any thoughts on how to solve this would be much appreciated, since
otherwise my wife will insist on moving back to Windows.

What worked was to recall how I had installed the player in the first place. I am using Debian Testing amd64 and thus I cannot install the player from Adobe in the usual Debian way. But the procedure listed under "Debian Testing 'Squeeze' amd64" on the following link worked.

At this time, here is the version of the player that I have:
flashplugin-nonfree                        2:

The audio is now working quite okay from my motherboard's audio but I am still unable to control its output from Pulseaudio, only the main mixer controls work. Oh well.



Please reply to this list only. I read this list on its corresponding
newsgroup on gmane.org. Replies sent to my email address are just
filtered to a folder in my mailbox and get periodically deleted without
ever having been read.

Reply to: