[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.32-3 does not recognize PATA WD disk... (SOLVED with 2.6.32-4 from sid)

On 04/28/2010 09:30 PM, Γιώργος Πάλλας wrote:
please don't top post! :-)

Answer at the end:

Anand Sivaram wrote:
This is not a kernel bug, but the way debian uses drivers.  There are
two different drivers in the kernel now.
Old ide drivers and newer pata drivers.  Old ide drivers are going to
get deprecated.
For some reason debian stock kernel is taking only ide drivers.  I
have seen this with both my desktop (ide amd74xx used, pata_amd is not
at all compiled) and laptop (both ide piix and pata ata_pii modules
are compiled, but ide piix used)
Because of that my hard drive is shown as /dev/hda instead of /dev/sda
with the debian stock kernel.

What I did was to compile a custom kernel by including only the pata drivers.
Now with this custom kernel everything is fine and consistent.

2010/4/28 Γιώργος Πάλλας<gpall@ccf.auth.gr>:

Hi to everybody!

I  just got a WD caviar blue, with the classic IDE interface and tried to
connect it to my debian squeeze pc which already has a WD SATA device, where
the OS lives.

The problem is that 2.6.32-3 does not recognize the disk and although I'm
not an expert, I tend to think that it is a kernel bug. I booted with
2.6.30-2-686 and it sees the disk:
[    1.560374] hda: WDC WD3200AAJB-56R1A0, ATA DISK drive

About the IDE controller, here's what lspci -v says:

on both 2.6.30  and 2.6.32 :

00:14.1 IDE interface: ATI Technologies Inc SB600 IDE (prog-if 8a [Master
SecP PriP])
       Subsystem: Giga-byte Technology Gigabyte GA-MA69G-S3H Motherboard
              Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
                    I/O ports at 01f0 [size=8]
                           I/O ports at 03f4 [size=1]
                                 I/O ports at 0170 [size=8]
                                       I/O ports at 0374 [size=1]
                                             I/O ports at f900 [size=16]
                                                    Kernel driver in use:
The only differences between lspci -v for 2.6.30 and 2.6.32 are the
# diff 2.6.30-2-lspci 2.6.32-3-lspci
<        Kernel driver in use: pcieport-driver

       Kernel driver in use: pcieport

<        Kernel driver in use: pcieport-driver

       Kernel driver in use: pcieport

<        Kernel driver in use: piix4_smbus

where the pcieport differences refer to
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external
gfx0 port A) (prog-if 00 [Normal decode])
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI
express gpp port F) (prog-if 00 [Normal decode])

The lshw utility shows almost perfect match between 2.6.30 and 2.6.32 with
the difference that under the ide section which is identical in both

            description: IDE interface
            product: SB600 IDE
            vendor: ATI Technologies Inc
            physical id: 14.1
            bus info: pci@0000:00:14.1
            version: 00
            width: 32 bits
            clock: 66MHz
            capabilities: ide bus_master
            configuration: driver=ATIIXP_IDE latency=32
            resources: irq:16 ioport:1f0(size=8) ioport:3f6
ioport:170(size=8) ioport:376 ioport:f900(size=16)
               description: IDE Channel 0
               physical id: 0
               bus info: ide@0
               logical name: ide0
               clock: 66MHz

but in 2.6.32 nothing disk relevant follows, where with 2.6.30, the disk
section follows:

                  description: ATA Disk
                  product: WDC WD3200AAJB-56R1A0
                  vendor: Western Digital
                  physical id: 0
                  bus info: ide@0.0
                  logical name: /dev/hda
                  version: 01.03E01
                  serial: WD-WCAV2H175667
                  size: 298GiB (320GB)
                  capabilities: ata dma lba iordy smart security pm
partitioned partitioned:dos
                  configuration: mode=udma5 signature=08040000 smart=on

bit strange, isn't it?

Any ideas?

As well as that, I can't report it via reportbug, because with: reportbug
I always get

Querying Debian BTS for reports on linux-2.6 (source)...
Unable to connect to Debian BTS; continue [y|N|?]?

after a couple of minutes...

That means that there is no way to get the disk working by using the
stock kernel? It is also strange that the drivers are there in the
2.6.32, but they do not seem to work:

[    1.256871] atiixp 0000:00:14.1: IDE controller (0x1002:0x438c rev 0x00)
[    1.256894] ATIIXP_IDE 0000:00:14.1: PCI INT A ->  GSI 16 (level, low)
->  IRQ 16
[    1.256909] atiixp 0000:00:14.1: not 100% native mode: will probe
irqs later
[    1.256915]     ide0: BM-DMA at 0xf900-0xf907
[    1.256923] Probing IDE interface ide0...
[    1.265866] ide0: no devices on the port

Any kernel expert to explain what exactly is happening here?

Anyway, I tried 2.6.32-4 from sid and the disk was recognized at once. So, it must have been a bug, though it struck me for passing into testing...


Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply to: