[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Firefox (and Iceweasel) are unable to play Youtube videos

Hash: SHA1

Nuno Magalhães <nunomagalhaes@eu.ipp.pt> writes:

> On Sat, Jan 30, 2010 at 10:58, Merciadri Luca
> <Luca.Merciadri@student.ulg.ac.be> wrote:
>> I have both `flash-plugin - Adobe Flash Player 10.0' on the two
>> computers. They are executing Iceweasel v. 3.0.6, and I also tried
>> with the up-to-date Firefox.
> I have this one:
> ii  flashplugin-nonfree 1:2.8
> running Sid on amd64.
Iceweasel gives me, amongst the add-ons:
Shockwave Flash 9.0 r100
Windows Media Player Plug-in 10

I tried deactivating the last one (i.e. Windows MP stuff), which was
causing some related trouble at others' browsers, if I understand the
whole correctly. (You might have a look at

A $ apt-cache search mplayer

gives me unuseful stuff, except

mplayer-skin-blue - blue skin for mplayer
mplayer-dbg - debugging symbols for MPlayer
mplayer-doc - documentation for MPlayer
mplayer - movie player for Unix-like systems
mozilla-mplayer - MPlayer-Plugin for Mozilla

Note however, that 

# apt-get -s remove mozilla-mplayer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package mozilla-mplayer is not installed, so not removed

It may not be the cause of the problem, somehow. I just wanted to
exclude any possibility...

Using the built-in Epiphany results in the same crashes (just with
Youtube). That looks normal as Epiphany is Gecko-based.

> Try with other browsers. Midori uses WebKit instead of Gecko, but it's
> crash-prone. There's Opera (Presto), kazehakase's also Gecko... and
> hell, there's IE.
For IE, it evidently works pretty well under Microsoft Windows XP, but
this is not the subject, isn't it?

> Run firefox from a terminal, that way you'll see the errors when it
> crashes.
That was the first thing I tried:

$ firefox http://www.youtube.com/watch?v=cY_KrB8Mepg
Unsupported movie property style with value ""
Unsupported movie property id with value "movie_player"
Unsupported movie property name with value "movie_player"
Unsupported movie property quality with value "high"
Unsupported movie property allowfullscreen with value "true"
Unsupported movie property allowscriptaccess with value "always"
Loading stream: http://s.ytimg.com/yt/swf/watch-vfl143348.swf
unhandled event 19

until there, NO crash at all (it is always so), as I have a really big
`Play' icon _in_ the flash plug-in: the Flash has not been played.

Then, some unuseful stuff:

Loading stream: http://www.youtube.com/get_video?video_id=cY_KrB8Mepg&t=vjVQa1PpcFNC0_Vmf7Tgh8pq2tVgZTgBGRuQEA1S28M=&el=detailpage&ps=&fmt=5&asv=2&noflv=1
Loading stream: http://v7.cache2.c.youtube.com/videoplayback?ip=
Loading stream: http://video-stats.video.google.com/s?ns=yt&docid=cY_KrB8Mepg&hl=en_US&cr=US&el=detailpage&fexp=903202&vid=aqSUfBzQpzyLVV7WYJF3KaH1uTg5Arf7C&csipt=watch&fmt=5&md=1&st=0.067&w=640&plid=AAR-ZjxkLeKATowr&vw=320&fv=WIN%209%2C0%2C100%2C0&sd=B4A7DD227MM&et=0.067&rt=2.8&len=254.4&bc=231338&vh=240&h=360

Once I have clicked, I can hear sound, and sometimes see an image from
the flash being played, but nothing more. The whole Iceweasel becomes
unresponsive, and I am obliged to kill the process. If I do not kill
it, it begins to stall completely, and freezes.

Any idea?

Thanks for your help.
- -- 
Merciadri Luca
See http://www.student.montefiore.ulg.ac.be/~merciadri/
- -- 

All that glisters is not gold. 
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Processed by Mailcrypt 3.5.8 <http://mailcrypt.sourceforge.net/>


Reply to: