[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Laptop won't resume from suspend to ram


I'm facing a very annoying problem with Debian testing on my laptop since this past weekend. Basically, the machine won't resume from a suspend to ram (resuming from suspend to disk works fine). It's not just a problem with a blank screen upon resuming; the machine actually gets completely frozen. I can hear the hard disk spinning though. I suspected it could be something to do with the wireless card (as the wireless LED doesn't come on when resuming), so I tried shutting down the network interface and unloading all kernel modules before putting the machine to sleep, but that didn't help. I tried kernels 2.6.30, 2.6.31 and 2.6.32 (the last two from Debian sid) with no luck. Furthermore, I suspect this problem is related to some package upgrade over the last few days, since everything was working just fine until last Friday or Saturday.

I wonder if anybody in this list has faced this problem. Any help in trying to pin this problem down would be greatly appreciated.

My machine is a Sony VaioVGN-NW130D laptop, with an Intel Wireless WiFi Link 5100 network interface and a Mobility RadeonHD 4570 video card (I'm using the radeon driver, not fglrx).

Thank you,


Yahoo! Canada Toolbar: Search from anywhere on the web, and bookmark your favourite sites. Download it now

Reply to: