[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Missing packages (apt), sshd and external usb large 1Tb drive


First of all I want to thank all your kind responses, it will help me a
lot to start using Debian. I will write a single message with comments for
all those who replied to me, to avoid flooding the list:

Now I know that not all of the DVDs are necessary. Respect the 'expert'
mode installation, when booted the DVD #1 it showed only "Install" and
"Graphic Install" (I have tried both of them), but at any moment saw the
expert or advanced installation, it just ran itself without asking
details. I will try the "Debian way" with most packages, and see if they
work for my needs, but at least kernel and mysql I need them from sources,
although will leave the original shiping package to avoid breaking
dependencies with httpd, etc.

Thanks for your message, I have a 32bit system, so I guess it will not be
problem the LILO, although by now I will keep GRUB while solving the most
important parts that are urgent to get my debian box fully functional.

I've just shut down the graphical login by the gdm. Respect KDE, you mean
that if I do "apt-get install kde" it will be fully installed, and
kde-core if only require the basics? Respect MySQL, in Slackware I used to
extract THE LIBRARIES from the package and leave them installed to let
httpd and php work fine since they are compiled with such libs, and apart
install MySQL at /usr/local from sources, setting up the PATH and MANPATH
to them. About LILO, am gonna google it.

I have already done the graphic login deactivation. Respect KDE I don't
understand what you mean with meta-packages, is it that there are
different versions of the same package? if so, how can I choose one of
them and know which ones are available? You mention ncurses, a moment ago
I was trying to compile the latest kernel, since my current installation
has no Qt tried "make menuconfig" and found there was no 'ncurses', tried
to install it via 'apt-get' but it reports there was any 'ncurses' package
available... does it come with the installation DVDs? or how can I specify
it to search for something on internet? Thanks!

Believe me, I did not find an expert mode installation. I booted the disc
#1 and it gave me only the text and graphic installation modes... I will
boot with the dvd and check again, anyway have not installed/configured
any package yet, so it may help to run the expert mode that is what I

I did the gdm deactivation, but am unable to to the rest since it asks for
the kernel with sources, but can't compile the kernel since some
packages/programs are missing and still don't find how to install them. I
will run the kde installation and in the mean time (I guess it will take a
while) will read the documentation and man pages for most of the utilities
that you all recommended me to use.

Now the new "problems" and doubts...

- Some packages/programs are missing, and 'apt-get' does not find them,
like qt (tried qt, qt3 and qt4), ncurses, ncurses-devel, etc. but apt says
they are not available. Where or how can I get a list of the full
available packages and its names? Apparently they are only retrieved from
the installation DVDs but not from an internet repository... I have never
used 'apt' but as far as I know I should configure a list of

- Derived from the previous situation, tried to compile qt3 to build a
kernel (make xconfig), but there are missing "X11/???.h" files... do I
have to 'apt-get install x11-devel" or something like? Don't know which
package install, I mean the name of the package, it should be x11-devel
but apt does not find such package :P

- My Debian box has ssh (openssh as I could see), but did not find a
'sshd' or similar... it has no server installed since am unable to connect
to default port 22... do I require a separate package and which one? and
how can I change the default port? Until now, I've always used the latest
Tectia free SSH version (3.x, since 4.x it is commercial) and configured
it by hand running "sshd -p #port"...

- I've just acquired a seagate freeagent usb drive, it was formatted to
ext3 but the filesystem got corrupted with my slackware... at first there
were simple differences between original and copied files at freeagent
drive, but after days the entire filesystem got corrupted. I reformatted
it to ntfs with windows and executed many test tools: FULL FORMAT (not
quick), Seagate Manager (test drive tool), TuneUP disk doctor (standard
and thorough analysis) and the drive appears to be fine... even tried to
reformat with 'fsck.ext3 -c -c' to ensure read and write test before
creating the filesystem and it does not report any problem, but when I
copy files to the usb and try a 'diff', it reports differences... that is
one of the multiple reasons that made me try Debian... My question here
is, if there is some special partitioning, formatting or disk geometry,
now with Debian of course, and if it is possible to leave it in NTFS for
rw... so I can use it with both Debian and Windows... I have tried ext2fsd
in read-only mode but don't know what could be more dangerous, to access
ntfs from Debian or to access ext3 from windows with ext2fsd r/w... Most
forums tell about a problem with the power saving spin-down and a solution
using a scsi allow_restart option that was already activated (did not need
to set it by hand), but the problem was data corruption... note that the
drive is new (less than 2 weeks) and apparently it passes all tests under
windows... my bet is that the problem was related to slackware and it will
work fine with debian, but is there any special treatment for such kind of

Again, thanks all of you for your time and patience.

Take care,

Reply to: