[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

CUPS Printing problems

I have just tried to move my printer from an old lenny system to my desktop (running sid).

I seem to have created a printer OK, but an attempt to print a test page fails. The view error log function on the cups web page shows the following (I have tried to pickup key parts from a VERY LONG file - debug is on at the moment)

D [02/Dec/2009:12:32:10 +0000] [Job 104] Running /usr/bin/pdftops -level2 -origpagesizes /var/spool/cups/tmp/pdftops.ZYEAkF - D [02/Dec/2009:12:32:10 +0000] [Job 104] Running pstops '104' 'root' 'Test Page' '1' ' job-uuid=urn:uuid:a4a29c47-6877-33a9-5cd4-02a51331b57c job-originating-host-name=localhost'
D [02/Dec/2009:12:32:10 +0000] [Job 104] Page size: A4
D [02/Dec/2009:12:32:10 +0000] [Job 104] Error: May not be a PDF file (continuing anyway) D [02/Dec/2009:12:32:10 +0000] [Job 104] Error: PDF file is damaged - attempting to reconstruct xref table... D [02/Dec/2009:12:32:10 +0000] [Job 104] Error: Couldn't find trailer dictionary
D [02/Dec/2009:12:32:10 +0000] [Job 104] Error: Couldn't read xref table
D [02/Dec/2009:12:32:10 +0000] [Job 104] Width: 595, height: 842, absolute margins: 18, 36, 577, 806
E [02/Dec/2009:12:32:10 +0000] [Job 104] Empty print file!

D [02/Dec/2009:12:32:11 +0000] [Job 104] Last OS error: 32
D [02/Dec/2009:12:32:11 +0000] [Job 104] GPL Ghostscript 8.70: Unrecoverable error, exit code 1 D [02/Dec/2009:12:32:11 +0000] [Job 104] GPL Ghostscript 8.70: ERROR -12 closing pdfwrite device. See gs/src/ierrors.h for code explanation. D [02/Dec/2009:12:32:11 +0000] PID 17774 (/usr/lib/cups/filter/pstopdf) stopped with status 1!

D [02/Dec/2009:12:32:17 +0000] [CGI] /usr/share/cups/drivers/pscript5.dll: No such file or directory

Can anyone tell from this what is wrong - the log against the job just says "/usr/lib/cups/filter/pdftopdf failed"

(I note in my older version of cups on lenny this filter didn't exist)

Alan Chandler

Reply to: