[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: where are the authentication settings for dovecot/imap stored?

Robert P. J. Day wrote:
>   on a lenny system, recently, someone else went in and reconfigured
> the authentication used for the mail system, and mail is currently
> working fine.  i now want to add a new email client (IMP, part of the
> horde framework) but i obviously need to configure it to match
> whatever the new mail authentication protocol is.  where can i find
> that?
>   for those who've actually worked with horde and IMP, here's what
> looks like the relevant snippet from the horde/imp/config/servers.php
> file:
> [snip IMP config]
>   i have good reason to believe that those settings are no longer
> correct, i just need to know how to figure out what they *should* be
> on this system.

IMP talks IMAP to a server. Is your dovecot listening in localhost:143,
without TLS? Try a 'telnet localhost 143' and see if you get the banner.

If dovecot is not listening for connections there, adjust the settings
in the IMP configuration. Or change dovecot's, whichever makes more
sense. Dovecot is configured via /etc/dovecot/dovecot.conf .

If the server is running and listening, does it authenticate if you try
manually, with something like:

#telnet localhost 143

Connected to localhost.
Escape character is '^]'.
* OK Dovecot ready.

1 login user password [substitute appropriate values here]

Paranoid Club meeting this Friday.  Now ... just try to find out where!


Reply to: