[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: vmware after kernel upgrade on lenny

On Wed, 4 Nov 2009 10:22:16 +0000, John O Laoi wrote:

> I am using lenny.
> I tried to use vmware workstation, and I got an error to the effect
> ...
> Anybody know what the problem might be?

I have no experience with Workstation but have succeeded twice in getting
VMware Server 1.0.6-91891 to run on Lenny.  It was tricky.  Here's a very
short summary (from the command line):

  Run   ./vmware-install.pl
  Reject the offer to run /usr/bin/vmware-config.pl
  Run a patch of vmmon and a patch of vmnet
  Remake vmmon.tar and vmnet.tar
  Run   CC=/usr/bin/gcc-4.1 /usr/bin/vmware-config.pl

and proceed from there normally.  You need the gcc-4.1 package for the last

I got the two patches as



and worked out the installation from instructions there.  Another useful site
(for Server) was:


Sorry if this is of no help with Workstation.  I've only used the free
Server.  I installed Server 2 but gave up on it.  My serial mouse and sound
didn't work, and I didn't like its management interface as well.  The only
reason I even tried 2 is because my USB scanner crashes 1; it still didn't
work with 2.

If anyone wants my detailed (long) log of how I installed Server 1.0.6 on
Lenny, I'll be happy to send it.

Reply to: