[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

vmware after kernel upgrade on lenny


I am using lenny.
I tried to use vmware workstation, and I got an error to the effect
that it could not find kernel headers.

So a little Googling told me that I had to do

aptitude  install linux-headers-$(uname -r)

But the above file did not exist.

So, I ran vmware again, and it told me that several modules need to be
compiled and installed, to which I pressed INSTALL. It asked me for
the root password, which I supplied, and a box with the heading
“vmware kernel module updater” appeared, which had 6 categories:
Virtual Machine Monitor
Virtual Network Device
Vmware blocking filesystem  etc.

On compileing the first, it stepped immediately with an error.
The error said to look in the file  /tmp/vmware-root/setup-6425.log.
This file contains the following:
# cat  /tmp/vmware-root/setup-6425.log

Nov 04 10:09:00.687: app| Log for VMware Workstation pid=6425
version=6.5.2 build=build-156735 option=Release

Nov 04 10:09:00.687: app| Host codepage=UTF-8 encoding=UTF-8

Nov 04 10:09:00.687: app| Logging to /tmp/vmware-root/setup-6425.log

Nov 04 10:09:01.898: app| Extracting the sources of the vmmon module.

Nov 04 10:09:01.955: app| Building module with command: /usr/bin/make
-C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1
HEADER_DIR=/lib/modules/2.6.30-2-686/build/include CC=/usr/bin/gcc
GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.3.4

I did a quick check.
Gcc is installed – it is in /usr/bin
/tmp/vmware-root/modules/vmmon-only    exists  - it is a directory
/lib/modules/2.6.30-2-686/build/include     exists  - it is a directory

Anybody know what the problem might be?


Reply to: