[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: usb-key files locked by unknown user

On Thu, 15 Oct 2009 16:42:08 +0000 (UTC)
debian-user-digest-request@lists.debian.org wrote:

> From: green <greenfreedom10@gmail.com>
> To: debian-user@lists.debian.org
> Subject: Re: usb-key files locked by unknown user
> Mark Grieveson wrote at 2009-10-15 09:32 -0500:
> > Hello.  Files on my usb-key (or flash drive, or whatever the correct
> > terminology is for these things) are locked for editing by an
> > unknown user (they're read only).  I'm not sure what's causing
> > this, 


> The usb/flash drive probably has the FAT32 filesystem on it, which
> does not
> support permissions.  Is it listed in /etc/fstab?  The 'owner' option
> there
> might fix your problem.

Thanks for the suggestion.  I tried it, but I still get the locking,
with the following message, 

"Document file 'yourfile.doc' is locked for editing by:

Unknown User

Open document read-only or open a copy of the document for editing."

This is similar to messages I've gotten in the past when I've opened a
file in one program and then, without closing that, opened the same
file in another program (or simply reopened the file again with the same
program) and had my computer tell me that it's being edited elsewhere,
and, thus, if I wish to open it for editing, I'll have to open a copy.

I don't get this issue on the Windows machines at school.  Also, I do
make sure that I follow the process for "safely removing storage
media" (or whatever the Windows phrase is for unmounting).  However,
in spite of this, I'm starting to think that it's not unmounting
properly from the Windows systems at school, and that this is
affecting it here at home.

Anyway, it's kind of annoying that I have to open copies of
everything when I'm working with the usb-stick at home (on Debian),
but have no problems when I work with it on any of the Windows
machines at school.  So, if there are any further thoughts, just send
them my way.


Reply to: