[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub2 not setting the vga= on one of 3 partitions SOLVED

Tom H wrote:
On Sat, Oct 17, 2009 at 2:03 AM, Wayne <linuxtwo@gmail.com> wrote:
I finally have grub 2 installed. Whew.  It works for testing but, does not
set the vga=31B on the stable entry.

Generating grub.cfg ...
Found Debian background: moreblue-orbit-grub.png
Found linux image: /boot/vmlinuz-2.6.30-2-amd64
Found initrd image: /boot/initrd.img-2.6.30-2-amd64
Found linux image: /boot/vmlinuz-2.6.30-1-amd64
Found initrd image: /boot/initrd.img-2.6.30-1-amd64
Found linux image: /boot/vmlinuz-2.6.26-2-amd64
Found initrd image: /boot/initrd.img-2.6.26-2-amd64
Warning: update-grub_lib is deprecated, use grub-mkconfig_lib instead
Found memtest86 image: /boot/memtest86.bin
Found memtest86+ image: /boot/memtest86+.bin
Found Debian GNU/Linux (sid) on /dev/sda8
Found Debian GNU/Linux (4.0) on /dev/sda9

The grub2 docs are, to say the least, sparce, and do not seem to have a
solution to this problem.
I have looked for a file that I could edit to fix this but come up empty.
 Anyone know where I can find it?
Anyone have a pointer it a fix?


I run testing primarily.

Fixed it. This may be of interest to others using the old grub and upgrading to grub2.

As I was using grub-legacy (0.97) I did not require grub on the sid and stable partitions. The one one testing worked for all 3 dists.

I had installed grub-legacy on sid and kept a backup menu.list in /boot/grub. I realized that and the fact that I had not done the same
on the stable partition.

I made a /boot/grub on stable and copied over the menu.list. Ran os-prober ; update-grub ; grub-install /dev/sda and the new/improved/better-then-grub grub2 finally got it right. Stable does not have grub installed because all that was needed was a menu.list file in /boot/grub for os-prober/grub2 to read from.

Hope this helps someone.


   give a man a fish, feed him for a day
   teach a man to fish, feed him for life

Reply to: