[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modifier keys stop working [second try]

On Wed, Aug 26, 2009 at 08:58:31PM -0400, Steve Kleene wrote:
> On Tue, 25 Aug 2009 19:34:48 -0400, I wrote:
> > I am repeatedly losing modifier-key function.
> > look into xmodmap. get the output of xmodmap both before and after the
> > problem. set up an .xmodmaprc file and then run it whenever you have a
> > problem with the VM borking them.
> I tried this without success.  First I ran xmodmap in sane mode and then in
> sick mode.  As expected, all the modifier key entries had become blank, e.g.
>   shift       Shift_L (0x32),  Shift_R (0x3e)
> was now
>   shift
> Next I made a shell file with lines of this sort (all from xmodmap -pke):
>   xmodmap -e "keycode  50 = Shift_L"

I think you should be running

   xmodmap -e "shift = Shift_L"

instead. Try that and see then if it assigns Shift_L to the shift

> I ran this after re-entering sick mode.  Some lines (e.g. the one above) ran
> without error, but others generated errors such as:
>   xmodmap:  unable to open file 'keycode 109 = Control_R' for reading

That sounds like a badly formatted command line to me. To do multiple
commands with xmodmap, it is easiest to put them in a file (I use
.xmodmaprc, the default config file). 

> In either case, the modifier keys still did nothing.  I guess I will just
> have to get used to running startx again.  I vaguely recall that in my
> Win4Lin days the VM screwed up some of the shortcuts I defined for
> fvwm.

I think it's surely a bug somewhere, as this shouldn't be
happening. Have you searched the BTS for possible clues?


Attachment: signature.asc
Description: Digital signature

Reply to: