[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem installing nvidia driver after upgrading from etch to lenny...



On Thu, 6 Aug 2009 02:27:26 +1000
Frank Gallacher <franxg@gmail.com> wrote:

> Greetings,
> 
> I have just upgraded from "etch" to "lenny" on my PC (kernel 2.6.26-2-686)
> I had installed the nvidia driver for NVIDIA GeForce 6600GT Graphics Card
> which was working OK,
> (Version 173.14.05 under etch)
> 
> After the upgrade, gdm was crashing saying it couldn't find the driver;
> When I tried to reinstall it, the installer complained about the version of
> gcc,
> saying it didn't exactly match the compiler used to compile the kernel (gcc
> 4.1).
> The installed compiler is:
> 
> gcc (Debian 4.3.2-1.1) 4.3.2
> 
> I downloaded the latest version of the nvidia driver (185.18.31) from the
> website;
> the same error message occurred...
> 
> Does anybody have any hints on how to get the driver loaded into a kernel???
> 

Install the package gcc-4.1 if it isn't installed already, and run

export CC=gcc-4.1 

before running the nvidia installer.

(Several versions of gcc can be installed at the same time, so you do
not loose the 4.3 version when installing the 4.1 version.)

best regards
-- 
Andreas Ronnquist <andreas.ronnquist@meritkonsult.se>


Reply to: