[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

installing alsa-driver-linuxant under Debian



Hi,

I've reported a problem in the linmodems mailing-list, but perhaps
someone can help me here. This is quite urgent (I hope to have some
answer before tomorrow).

I'm trying to build alsa-driver-linuxant on a Debian/unstable machine
(amd64). I got the alsa-driver-linuxant Debian package from the
Linuxant web site; this is a package that contains the sources, that
need to be compiled (this is normally done in the postinst script,
but the build fails). So, if someone here has managed to build the
driver under Debian (or has some URL about someone who did), I'd be
very interested.

For the moment, I did the following. First the kernel sources must be
installed (the headers are not sufficient):

# apt-get install linux-source-2.6.30
$ cd /usr/src
$ atool -eqx linux-source-2.6.30.tar.bz2
$ cd linux-source-2.6.30
$ make oldconfig && make prepare
# cd /usr/lib/alsa-driver-linuxant
# ./configure --with-kernel=/usr/src/linux-source-2.6.30 --with-build=/usr/src/linux-kbuild-2.6.30
# make

but "make" fails with an error about scripts/genksyms/genksyms that
can't be found. I could solve this error by adding

GENKSYMS = /usr/src/linux-kbuild-2.6.30/scripts/genksyms/genksyms

to the Makefile.conf (in /usr/lib/alsa-driver-linuxant). Then I tried
"make" again, but got the following error:

/bin/sh: scripts/mod/modpost: No such file or directory

scripts/mod/modpost is also in /usr/src/linux-kbuild-2.6.30, but
I don't know which file to modify in order to provide the path.
Just in case, I tried

  MODPOST = /usr/src/linux-kbuild-2.6.30/scripts/mod/modpost

in alsa-driver-linuxant's Makefile.conf, but this has no effect.

TIA for any information,

-- 
Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)


Reply to: