[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Midori dependencies problem with sid



In <20090528135056.GB13101@emurlahn.burrows.local>, Daniel Burrows wrote:
>On Wed, May 27, 2009 at 10:59:50AM -0500, "Boyd Stephen Smith Jr." 
<bss@iguanasuicide.net> was heard to say:
>> You have the package "libwebkit-1.0-2" version "1.1.7-1".  But, the
>> package "midori" needs the package "libwebkit-1.0-1" version "1.0.1" or
>> greater. Package names are only compared for equality; they aren't ordered
>> and a request for one package cannot be satisfied by another package
>> without an explicit Provides relationship.
>
>  Also, a request for a package with a version constraint can never
>be satisfied by another package, even if a Provides relationship
>exists.

Isn't that supposed to change in the future (but perhaps not before Squeeze) 
so that we can have versioned dependencies on virtual packages?
-- 
Boyd Stephen Smith Jr.                   ,= ,-_-. =.
bss@iguanasuicide.net                   ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy         `-'(. .)`-'
http://iguanasuicide.net/                    \_/

Attachment: signature.asc
Description: This is a digitally signed message part.


Reply to: