[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian squeeze (testing) dns problems

On Fri, May 08, 2009 at 08:28:15 -0400, Hugh Lawson (hlawson@triad.rr.com) wrote: 

> Hello,
> I hope there will be some suggestions for this. This is a single-user 
> box, managed by an amateur (me).  This is surprising and baffling; it 
> makes me suspect I've made some basic error in configuration, but I 
> can't find it.
> My newly installed squeeze has problems with DNS.  Specificially, Emacs 
> gnus and evolution cannot reliably find their respective servers.  
> If I configure the applications with 'pop-server.triad.rr.com', for 
> example, they report that they cannot find the server.  But if I 
> configure them with the IP of the server,they work OK.
> OTOH iceweasel works fine.
> As far as I can tell, nslookup, ping, and host work as expected.  
> A lenny install on the same hardware works fine.
> Things I've already tried:
> Configuring applications with IP rather that URL of server. Works
> Changing the name-servers in /etc/resolv.conf--makes no difference.
> Reinstalling squeeze with a later netinst cd--makes no difference.

Presumably, the applications you mention as having problems are using
fetchmail to retrieve mail from pop-server.triad.rr.com?

What do you see if you run fetchmail directly from the command line with
fetchmail -vvv ?

(I have just tried this from here with a dummy username and password and
connected successfully with pop-server.triad.rr.com on the POP3 port,

fetchmail: 6.3.9-rc2 querying pop-server.triad.rr.com (protocol POP3) at Fri 08 May 2009 14:18:40 BST: poll started
Trying to connect to
fetchmail: POP3< +OK POP3 server ready.
fetchmail: POP3> CAPA
fetchmail: POP3< +OK Capability list follows
fetchmail: POP3< TOP
fetchmail: POP3< USER
fetchmail: POP3< RESP_CODES
fetchmail: POP3< PIPELINING
fetchmail: POP3< EXPIRE NEVER
fetchmail: POP3< UIDL
fetchmail: POP3< .
fetchmail: pop-server.triad.rr.com: opportunistic upgrade to TLS failed, trying to continue.
fetchmail: POP3> USER test
fetchmail: POP3< +OK please send PASS command
fetchmail: POP3> PASS *
fetchmail: POP3< -ERR invalid user name or password.

Bob Cox.  Stoke Gifford, near Bristol, UK.
Please reply to the list only.  Do NOT send copies directly to me.

Reply to: