[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.18 Modular Kernel has No Sound.

On Saturday 02 May 2009 05:15:06 Martin McCormick wrote:
> 	I have an etch system that has been running a 2.6.5
> kernel and it is time to upgrade it to something more  modern.
> The 2.6.5 kernel worked well but our organization is using VPN
> so I need to update things so that vpnc will work.
> 	After a coworker convinced me to try a modular kernel
> instead of building another one, I downloaded
> what appears to be the newest kernel from debian.org:
> #aptitude install linux-image-2.6-686
> 	This got a 2.6.18 modular kernel so I tried it. It
> appears to work fine except for sound. My old kernel works
> beautifully with alsa. The new kernel actually found the sound
> card but then begin complaining that the sound device was busy
> during the boot process. Game over for sound.
> 	Everything else appears fine.
> 	Is there any way to guide this process a bit to make the
> sound work again?
> 	I now know the recommended way to build a custom kernel
> so I could fall back to doing that again, but surely there is a
> way to get the CS4236 sound chips matched up with the right
> module.
> 	Fortunately, grub still points to the old kernel by
> default for now so, for the time being, I am back to the 2.6.5
> kernel and sound pouring out of the speakers.:-)
> Martin McCormick

The cs4xx driver has indeed been removed from the debian kernel (some file 
missing copyright information i belive) you may download and compile the alsa 
modules by hand or (I think) you may use module-assistant to help you do this 
the “debian” way.


Reply to: