[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: upgrading the kernel in debian etch from 2.6.18 to 2.6.29

|>  But i still got the error about can finding vg_maingroup which i  
|> believe is my main filesystem.

I strongly suspect that you are trying to boot a kernel which does not
include LVM support. (Partly because I had very similar problems in
upgrading to 2.6.29 from 2.6.22 and this was the reason). The way that
LVM support is handled in the kernel has changed. 

There is a separate section in the configuration menu: under Device
Drivers, in a subsection called Multiple Devices Driver Support. In
there (apart from all of the Raid options) there is an option called 
Device Mapper Support (if you configure it as a module it's called
dm-mod). If this option is not enabled (as a module or otherwise) the
kernel cannot boot a system whose root directory is on an LVM module.


Reply to: