[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

realtek RTL8168C/8111C performance issues


I've been using Debian for approx 5 years. I'm in the process of building me a new NAS machine. To that end i have bought a small NAS chassis and a DG945GCLF2 wich has a atom 330 and realtek RTL8168C/8111 NIC. I have everything hooked up to a Dink DGS-1008D gigbit switch

I installed lenny and tested hdperfomance on my software raid0 and got approx 120mb/s write with DD

Then i went to test the network and realised i got really crappy performance for being Gigabit. I used iperf and got 116 mbit/s.When i do iperf between my stationary machines i get 914mbit/s and a transfer speed in the range of 70-80 MB/s.when i do ftp and such.

I saw that i had a lot of dropped packages but I got that solved by installing the latest drivers from realtek based from the instructions here http://www.jamesonwilliams.com/hardy-r8168.html

But still the network performance still was as bad as before. So i tried a lot of different things

* I exchanged all the patch cables with new ones
       -- No change
* Removed all the other devices from the router except the NAS and the main machines -- First i got no change, then all of a sudden for some time i got 914 Mb/s
* I connected the NAS directly to my main stationary machine
-- Again i mostly really crappy and then again i got full speed for a 10 min or so

The biggest problem is that i havn't been able to find a setup that result in consistently good performance.

I thinking of trying a separate NIC but then i have to loose the case as it dosn't fit so if i could find a solution that works with the onboard NIC i would be very glad.

Any help or suggestions would be highly appriciated as i have scanned the net for days without finding any good leads.



Reply to: