[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Apple OS X printing [solved] and zeroconf'ing problems

I have a Debian Lenny box at home, and just tried to print to it from an
OS X 10.4 (Tiger) laptop connected to my home printer.

CUPS is apparently supposed to advertise on zeroconf, but it did not
show up when I browsed in the Apple add printer dialog.  

For the record, I was finally able to print by selecting "internet
printer" in that dialogue, giving it the name of my system, and
specifying printers/Duplex in the queues field (Duplex is one of my CUPS
printer names).

I also tweaked my cupsd.conf before doing this:
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseAddress @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
  Order allow,deny
  Allow from
  AuthType None

It's not clear that OS X print facilities can handle giving a name and
password; so I turned off authentication (AuthType None).  I'm not sure
how many of these settings were necessary.

I never got anything to show up in the add printer browser on OS X.
Although I understand CUPS is supposed to advertise itself (at least
with the settings I gave it), I also tried
creating /etc/avahi/services/printers:

  <name replace-wildcards="yes">Printer on %h</name>

<!--     <subtype>_colour._sub._ipp._tcp</subtype> -->
    <txt-record>note=Ross's Office</txt-record>
    <txt-record>ty=Brother HL-5150D</txt-record>

<!--   <service protocol="ipv6"> -->
<!--     <type>_uberprinter._tcp</type> -->
<!--     <domain-name>local</domain-name> -->
<!--     <host-name>xxx.us</host-name> -->
<!--     <port>4711</port> -->
<!--     <txt-record>this=is</txt-record> -->
<!--     <txt-record>a=really</txt-record> -->
<!--     <txt-record>bad=example</txt-record> -->
<!--   </service> -->


I restarted both CUPS and avahi, and I believe my firewall is letting
all local traffic through.  Also, the Mac was able to see my cups home
page with firefox on http://xxx.us:631.

On the CUPS admin page the box next to "Allow printing from the
internet" is not checked.  I don't know what that means.

Any ideas what's going on?

Reply to: