[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Adding installed packages to menu

On Wed, 4 Mar 2009, Daniel Burrows wrote:

On Tue, Mar 03, 2009 at 01:51:20AM +0900, Bret Busby <bret@busby.net> was heard to say:
The package is flightgear, the Flight Gear Flight simulator.

 I installed flightgear on my computer overnight to test this myself,
and it does appear to go into the Gnome menu, under
"Applications -> Games".  Its .desktop file should look like this:

$ cat /usr/share/applications/flightgear.desktop
[Desktop Entry]
Comment=A flight simulator
Comment[pt]=Simulação de Vôo


I tried as the user, and was unsuccessful with the above command, so, assuming that privilege was restricted to the root account, tried as root;

bret@bretnewworkstation:~$ cat /usr/share/applications/flightgear.desktop cat: /usr/share/applications/flightgear.desktop: No such file or directory
bret@bretnewworkstation:~$ su - root
bretnewworkstation:~# cat /usr/share/applications/flightgear.desktop
cat: /usr/share/applications/flightgear.desktop: No such file or directory

So, it is not shown there.

From history in Synaptic;

"Commit Log for Mon Mar  2 13:41:22 2009

Installed the following packages:
fgfs-base (0.9.10-1)
flightgear (0.9.10-2)
freeglut3 (2.4.0-5)
libalut0 (1.0.1-1)
libopenal0a (1:0.0.8-4)
plib1.8.4c2 (1.8.4-6)
simgear0 (0.3.10-2)

So, the package and its dependencies show as having been installed, but no .desktop file was apparently created.

Bret Busby
West Australia

"So once you do know what the question actually is,
 you'll know what the answer means."
- Deep Thought,
  Chapter 28 of Book 1 of
  "The Hitchhiker's Guide to the Galaxy:
  A Trilogy In Four Parts",
  written by Douglas Adams,
  published by Pan Books, 1992


Reply to: