[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOLVED] where is bind9's named_dump.db

Hash: SHA1

Ken Teague wrote:

> I found this which may help:
> dump-file
>  dump-file path_name;
> dump-file is a quoted string defining the absolute path where BIND dumps
> the database (cache) in response to a rndc dumpdb. If not specified, the
> default is named_dump.db in the location specified by a directory
> option. This option may only be specified in a 'global' options statement.

Thank you so much, Ken. That solved the problem.

In /etc/default/ is a file that is sourced into the bind9 startup script
and causes bind9 to run as user 'bind'.

In named.conf.options, there is a directory option: /etc/bind. And the
permissions are indeed wrong for user 'bind' to write into:

drwxr-sr-x   2 root   bind   4.0K 2009-02-03 20:59 bind

Adding 'dump-file "/tmp/named_dump.db"' to the named config options made
it work -- and put the file where I could find it. Something like this
(or changing permissions on the directory) must be done on Debian
systems if the 'rndc dumpdb' command is to work.

It occurs to me that the config from the .deb might not really need to
be so Byzantine.

- --
Glenn English

Version: GnuPG v1.4.8 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: