[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: grub with sata drives? - Progress

On Mon, Nov 03, 2008 at 03:00:56PM -0600, elijah rutschman wrote:
> On Mon, Nov 3, 2008 at 2:28 PM, Thomas H. George <lists@tomgeorge.info> wrote:
> > I have two sata drives, sda and sdb with the root partition on sdb.  I
> > installed grub on sdb and made the following entries in
> > /boot/grub/menu.lst:
> As far as I know, grub doesn't use the Linux /dev/ nodes to access
> disks.  The syntax for both IDE and SATA drives should be the same for
> your menu.lst, so something along the lines of groot=(hd0,0).  Since
> you are using the secondary drive (in Linux, /dev/sdb) I guess it
> would probably be groot=(hd1,0).  You'd still want kopt=root=/dev/sdb1
> as it is though, since that parameter is intended for the kernel and
> not the bootloader.
> -Elijah
Well groot=(hd2,0) works - that is, when trying to boot I now get a

root  (hd2,0)
  Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-1-amd64 root=/dev/sdb1 ro

Error 15: File not found

Needless to say I have tried all sorts of variants in place of sdb1
without success.  This is particularly frustrating as I can boot the
sytem with lilo with root=/dev/sdb1 specified in lilo.conf.  That is to
say I can boot the system with lilo using kernel image
vmlinuz-2.6.24-1-amd64.  lilo will not boot with kernel image
vmlinuz-2.6.26-1-amd64 because initrd.img-2.6.26-1-amd64 is too large.
That is why I am trying to use grub and - yes - I have tried grub with
the vmlinuz-2.6.24-1-amd64 kernel image with the same results cited


Reply to: