[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem compiling 2.6.26 kernel

On 09/28/2008 02:49 PM, Arthur Barlow wrote:

I did check the settings in .config. Both BLK_DEV_IDE and BLK_DEV_IDEDISK are set to "y." As for the ATA/SATA settings, they were not set, but my disk is an older one and should not care, but I tried setting them and trying again, and I got the same result.

The drive is a Western Digital 40G drive, model WDC WD400JB-00FMA0. As I mentioned it's using Reiserfs 3.6. Also I got the source code from Debian's repository. It's just a Debianized tar ball.

That is quite confusing. As the boot messages fly by, you can stop them by using Control-S. Another Control-S allows the boot-up to continue. Use that method to pause the display long enough for you to see how your IDE drives are recognized by the kernel. I have messages like these:

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
hda: HDS728080PLAT20, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14

I would hope that you have something similar. Also try roots of /dev/hdb1 and /dev/hdc1 and /dev/sda1. Even though those are not likely to work, it's probably worth a try. Can we see the entire boot stanza used by LILO?

Reply to: