[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unpredictable behaviour of Sata in Lenny



Hi,
   I am facing a weird problem in Lenny, till now I have been running Etch without any problem. Two days ago I upgraded to Lenny, installation went smooth, I was able to install Nvidia drivers properly. Everything ran OK. But then I shutdown my system (power-off) and tried to power on again after a couple of minutes. The system booted to Grub, I chose linux to boot into (I have dual boot with Lenny and XP) it went until certain point and then displayed error saying :

 "Sata link is down, taking too much time to respond."
"SRST failed (error -16)."

After then it displayed
"slowing down the SATA link to 1.5 GHz "

again the same SATA errors and it left me on the prompt with  initramfs prompt.

I tried resetting my system couple of times but of no avail. Then I tried booting into XP to see whether there is something really wrong with my drive, I logged in to XP successfully. Re-booted the system again and this time booted into linux and to my surprise everything ran fine.

I tried to generate the same scenario just to make sure whether it was one off case, but it wasn't. Now if want to power on my PC, I need to boot in to windows first and then reboot my system into linux. I can't log into Linux from power on, directly.

I checked my BIOS to make sure if anything in BIOS is wrong, but nothing seems wrong with my BIOS. I have 4 sata ports on my Mother Board and the disk is connected to port number 2. I have DVD drive connected to IDE port. My boot preference is Hard disk first ( dunno whether this information is of any relevence).

There seems to be a problem with my Lan also, sometimes it shows limited connectivity and to correct this also I need to boot in to windows.

I have a Intel Q660 system with Nvidia Mother board and 9600GT graphics card. I installed the driver provided by Nvidia in Nvidia way (not the Debian way) hope this is not the cause of the problem.

Anybody, please help me out on this in locating what the problem might be. I want to look into the details of the problem but have got no clue where to start with and what the cause might be.

Thanks in advance
       Mridul

Reply to: