[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot switch to VT (console)

On 23/07/08 14:38, Raj Kiran Grandhi wrote:
Michal R. Hoffmann wrote:

Recently I tried to switch to VT (console) and I couldn't - Ctrl+Alt+F1 didn't work (and they used to couple of weeks ago). I don't even know where to look for the problem; xev detects KeyRelease XF86_Switch_VT_1 event, /etc/inittab contain getty respawns.

Check your xorg.conf and see if the DontVTSwitch option is present.
No, it's not.

Also, it could be some problem with your XkbModel setting, like pc105 instead of pc104.
Hmmm, that's possible - I have that Microsoft ergonomical USB keyboard, connected via Avocent KVM. But it worked previously... And xev detects the XF86_Switch_VT_1 event so it seems to be OK.

Oh, when I tried chvt 1 it responded:
Couldnt get a file descriptor referring to the console
Did you try that as root?
Just tried and it worked; so maybe this is some access rights issue then?

Kind regards,
Michal R. Hoffmann

Reply to: