[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Squirrelmail:115 Can't Open SMTP Stream.



Hi all.
I asked this problem to squirrelmail-users mail list but I could not answer about this problem so If it doesn't problem,I want to ask this problem to debian users mail list.
 
I have Debian 4.0 Etch and i use Postfix 2.3.8-2 and Dovecot 1.0.rc15-2etch4 IMAP and POP3 Server that is TLS support.I am using Mysql for Virtual domain and authentication.

But i have error on browser like this:"Operation now in progress
Server replied: 115 Can't open SMTP stream." when i try send email on squirrelmail.I have not a problem(All Authentication and all rules work without any problem) when i use Thunderbird or Evolution.
I searched this error on google but i can not find beneficial post or documents about this problem.

If I dont use TLS parameters on Postfix main.cf,squirrelmail send email without any problem but If I use TLS or choose "Secure SMTP (TLS)     : false" on squirrelmail "Server Setting",squirrelmail dont sent email.

Squirrelmail "Server Setting" configuration like below:

General
-------
1.  Domain                 : xyz.com
2.  Invert Time            : false
3.  Sendmail or SMTP       : SMTP

SMTP Settings
-------------
4.   SMTP Server           : 127.0.0.1
5.   SMTP Port             : 25
6.   POP before SMTP       : false
7.   SMTP Authentication   : login
8.   Secure SMTP (TLS)     : true
9.   Header encryption key :

and output from mail.log with TLS support like below:

#
Jul 14 11:05:48 debian postfix/smtpd[4403]: connect from localhost[127.0.0.1]
Jul 14 11:05:48 debian postfix/smtpd[4403]: lost connection after UNKNOWN from localhost[127.0.0.1]
Jul 14 11:05:48 debian postfix/smtpd[4403]: disconnect from localhost[127.0.0.1]
#

and output from mail.log without TLS support (removed TLS parameters from main.cf and choosed "false" on squirrelmail Server Setting-Secure SMTP (TLS)     : false):

#
Jul 14 11:06:46 debian postfix/smtpd[4463]: connect from localhost[127.0.0.1]
Jul 14 11:06:46 debian postfix/smtpd[4463]: E0ED83781E: client=localhost[127.0.0.1], sasl_method=LOGIN, sasl_username=a@xyz.com
Jul 14 11:06:46 debian postfix/cleanup[4467]: E0ED83781E: message-id=<e6ca13963aa61e59633f26690f8c9334.squirrel@mail.xyz.com>
Jul 14 11:06:46 debian postfix/qmgr[4401]: E0ED83781E: from=<a@xyz.com>, size=726, nrcpt=1 (queue active)
Jul 14 11:06:46 debian dovecot: imap-login: Login: user=<a@xyz.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Jul 14 11:06:47 debian postfix/smtpd[4463]: disconnect from localhost[127.0.0.1]
Jul 14 11:06:47 debian dovecot: IMAP(a@xyz.com): Disconnected: Logged out
#

I have only posted about TLS configuration parameters in Postfix main.cf like below:

smtpd_use_tls=yes
smtpd_tls_cert_file=/etc/ssl/certs/postfix.pem
smtpd_tls_key_file=/etc/ssl/private/postfix.pem
smtpd_tls_auth_only=yes

If I disable TLS,I have non-security authentication with email client programs(because auth is plain text) so I dont want to disable TLS.

What should i do for use squirrelmail without TLS problem ?

Thanks.


Iyi calismalar.Basarilar...
Semih Gokalp
Istanbul/Turkiye

Reply to: