[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Firefox not showing in Applications menus

On Sat, 12 Jul 2008, Hugo Vanwoerkom wrote:

Bret Busby wrote:


I have Firefox installed on my system (Debian 4.0), and today an update for firefox showed, and was installed using the system update system.

With the recent problems with Iceape, I thought that I would try Firefox.

Synaptic shows that I have Firefox installed, but I can't find it in the Applications menus.

I have looked in both the top level Internet menu, and in the Debian->Apps->Net menu, and in the Office menu (in case it got inserted in there), and the Other menu, but I cannot find Firefox.

How do I run Firefox, if I cannot find it, and, why, when it is installed, and, updated by the orange star icon that shows updates are available, does it not appear in the Applications menus?

You really mean FF or iceweasel?

hugo@debian:~$ which firefox
hugo@debian:~$ which iceweasel



Firstly, I have (or, I understood that I have) both Firefox and Iceweasel installed. I wanted to try Firefox (separate to Iceape and Iceweasel), to find whether it had greater stability and security than Iceape and Iceweasel.

I was also (in addition to the response above) sent the following instructions, off-list:

1 -you need to find firefox path , just type this command :

locate firefox

then u will get somthing like :


2- you have to edit menu by :

right-click on Applications then select  Edit Menus

It kind of worked....

When I did the locate firefox command, it gave an interesting response. The response had groups of about four lines, with dates in the text. None of the
responses had the /usr/bin.firefox path.

I then used the alacarte menu editor (the only way that I found, of editing the menus - remember, this is Debian 4.0), and manually inserted Firefox as an
entry, with the invocation comand /usr/bin/firefox.

Then, when I closed that, and ran the Firefox comand from the menu, it added another session of Iceweasel to my already open Iceweasel windows (I hadn't used
Iceweasel for months, due to an application crash, and was bookmarking the windows of the last session, and shutting Iceweasel windows, as I went, so had
some Iceweasel windows open), and, renamed the task in the taskbar, to Firefox.

I also ran the update-menus command,as mentioned above, and then ran Firefox from the menu, again, and got the same response.

I also note that both Firefox and Iceweasel, have the same icon, in the icon editor that I used when I manually added Firefox to the menu.

So, now, it appears to me, that the Firefox that is installed (Firefox and Iceweasel (Iceweasel are one and the same.

It gets confusinger and confusinger.

Bret Busby
West Australia

"So once you do know what the question actually is,
 you'll know what the answer means."
- Deep Thought,
  Chapter 28 of Book 1 of
  "The Hitchhiker's Guide to the Galaxy:
  A Trilogy In Four Parts",
  written by Douglas Adams,
  published by Pan Books, 1992


Reply to: