[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cupsys does not print: update

Damon L. Chesser wrote:
Two systems: amd64 and i386. Both ran Sid. printer is networked with Added printer via localhost:631 as a network (LPD) printer url is lpd://

The printer comes to life, the data light blinks (Samsung ML-1430) then the server stops making noise but the data light keeps blinking. No paper comes out.

re-installed i386 to stable, re-add the printer via gnome-cups-manager, tested, same results. So this is not a Sid issue.

tested from a win box, prints fine.

tested from ubuntu live (thinking maybe the Hawkings tech. print server was going bad), prints fine.

This worked a month ago on Sid (amd64 box) before I test drove ubuntu.

I don't see any obvious bug reports.

I don't see a flood of messages coming across here.

Nothing in the cups error log:
E [04/Apr/2008:14:04:57 -0400] PID 26233 (/usr/lib/cups/backend/lpd) stopped with status 1!
E [04/Apr/2008:14:06:54 -0400] CUPS-Add-Modify-Printer: Unauthorized
E [04/Apr/2008:14:19:57 -0400] CUPS-Add-Modify-Printer: Unauthorized
E [04/Apr/2008:14:19:59 -0400] CUPS-Add-Modify-Printer: Unauthorized

all messages there are accounted for.

the print jobs just stays in the print spool.

All this is very strange. I have not had this issue before (though I have had printing killed in sid, never in sid and stable). What to do?

Ok, found out it is kernel related. re-installed stable and did NO updates (even security updates), tested cupsys, it worked. Did security updates, got a new kernel.

output of uname -a for both kernels:

Linux dam-main-deb 2.6.22-3-amd64 #1 SMP Sun Nov 4 18:18:09 UTC 2007 x86_64 GNU/Linux Linux dam-main-deb 2.6.24-1-amd64 #1 SMP Fri Apr 18 23:08:22 UTC 2008 x86_64 GNU/Linux

The new kernel did not print to cupsys printer, but the spool (blinking lights and network activity) looks like it is transmitting very slowly. Eventually the printer will print an error report. This takes so long, only once have I gotten one.

Ok, so 2.6.24-1 is bad for me. I grabbed the latest kernel source from kernel.org and made a kernel (2.6.25). Same issue.

So, what do I do now, who do I file a bug report to? This is not a debian patch (kernel.org source had same issue), not a cupsys bug. Same package load out works with 2.6.22 but not with >2.6.22.

btw, at this point I am on Sid with a 2.6.22-3-amd64 kernel or a 2.66.25 custom kernel (used 2.6.22 config to make)

I am at a loss as how to fix this, any help would be appreciated.

Damon L. Chesser

Reply to: