[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dmesg reports connection of mass storage device but no kde pop-up nor device file created

On Mon, Mar 31, 2008 at 23:08:32 +1030, Arthur Marsh wrote:
> I plugged in a USB mass storage device into my pc running Debian  
> Unstable and unlike several months ago, did not get a notification from  
> KDE that the device had been discovered.

Did you choose a default action for that type of device when the
notification first appeared? AFAIK, KDE will not pop up the notification
again once the user has selected a default action (and this default
action can be "do nothing").

> dmesg reported:
> usb 2-2: new full speed USB device using ohci_hcd and address 4
> usb 2-2: configuration #1 chosen from 1 choice
> usb 2-2: New USB device found, idVendor=0944, idProduct=0001
> usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
> usb 2-2: Product: PXR4
> usb 2-2: Manufacturer: KORG INC.

Is that the complete output? It seems that no device node(s) was/were

> Is any customisation needed for udev / HAL to create a device file when  
> this device is discovered? I'd like it to auto-mount as /mnt/usbdrive

Normally this should "just work". I run KDE on Sid/amd64 and I have not
noticed a problem with this in ages; I don't have the same storage
device, though. Can you post the output that you get when you run

lshal --monitor

and plug in the device? (CTRL-C to stop, but wait for at least 10
seconds after you plug in the device.)

Regards,            | http://users.icfo.es/Florian.Kulzer
          Florian   |

Reply to: