[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: etch nvidia xorg nvidia-glx-legacy X crashes

On 24 Mar 2008 20:43:26 -0400, Hugh Lawson <hlawson@triad.rr.com> wrote:

I've been trying to install the nvidia driver.  I managed to get it
working, but my solution is not entirely satisfactory, because it's
vulnerable to an update of the nvidia-glx-legacy package.  I'll trace
through the problem, and perhaps somebody can point to a better way.

Debian etch
nVidia Corporation NV28 [GeForce4 Ti 4200 AGP 8x] (rev a1)
NVIDIA-Linux-x86-96.43.01-pkg1.run ("the installer")

I used the  installer to compile and install the nvidia video
driver module, but X crashed on next boot.  I couldn't find any
documentation warning about this after much searching.  I did however
figure out what was causing the problem.

The init file /etc/init.d/nvidia-glx-legacy was causing the X crashes,
by fiddling with needed links and file locations in the libraries.  I
fixed this by the following:

# cd /etc/init.d
# mv nvidia-glx-legacy XXnvidia-glx-legacy

How I tested this:

First I installed the module
#  sh NVIDIA-Linux-x86-96.43.01-pkg1.run

Upon success, I rebooted.  Then X failed to run.  So I used a rescue
linux to edit /etc/X11/xorg.conf to use the "nv" driver rather than
the "nvidia" one, and rebooted again.

Then I tested the installation of the nvidia module.

# sh NVIDIA-Linux-x86-96.43.01-pkg1.run  --sanity

The output of this program showed that files were missing, so I
installed the nvidia module once more:

#  sh NVIDIA-Linux-x86-96.43.01-pkg1.run

Staying in the console, I ran this:

# sh NVIDIA-Linux-x86-96.43.01-pkg1.run  --sanity

No missing files. Then I ran:

#  /etc/init.d/nvidia-glx-legacy

and ran the sanity check once more:

# sh NVIDIA-Linux-x86-96.43.01-pkg1.run  --sanity

The sanity check showed files were missing again. So, I installed the
nvidia module once more:

#  sh NVIDIA-Linux-x86-96.43.01-pkg1.run

and did this:

# mv nvidia-glx-legacy XXnvidia-glx-legacy

Upon reboot, the nvidia logo appeared and X started normally.

QED: /etc/init.d/nvidia-glx-legacy, a part of the nvidia-glx-legacy package
makes it impossible for me to use the nvidia video driver, as
installed by NVIDIA-Linux-x86-96.43.01-pkg1.run


  Are you using the legacy drivers or are they simply being installed alongside and causing issues?

  The nvidia-glx-legacy isn't for the Geforce4 line:

From `apt-cache show nvidia-glx-legacy`:

Description: NVIDIA binary XFree86 4.x/X.Org 'legacy' driver
These XFree86 4.x/X.Org binary drivers provide optimized hardware acceleration
of OpenGL applications via a direct-rendering X Server and supports the TNT,
TNT2, TNT Ultra, GeForce, and GeForce2 chipsets. AGP, TV-out and flat panel
displays are also supported.
This is the 'legacy' driver for older chipsets. Unless your chipset is
explicitly listed in the above paragraph, please use the nvidia-glx driver,
which is much more up to date.


Reply to: