[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrade from sarge to etch - package dependencies issues

On Sun, Feb 03, 2008 at 10:41:11PM +0000, Dimitrios Daskalakis wrote:
> Hi,
> I am trying to upgrade my distribution from sarge to
> etch.
> Having upgraded successfully the 2.4 kernel to 2.6, I
> update my sources.list (change sarge to stable, so I
> get etch) and I run aptitude upgrade. Then ...
> aptitude   dist-upgrade
> which unfortunately gives me these errors:

You need aptitude update so that aptitude knows the new versions of

Also,  I use aptitude interactively, and tell it (in the menus) not to
treat recommends as strong dependancies.

Also, I hope you have a solid and tested backup.  It _should_ go
smoothly, but I had libc die (killed the whole system) on one of my
boxes during the transistion.

Good luck.


Reply to: