[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

No sound on a ThinkPad T61 w/ a AD1984 sound card

Hello there,

I've been unable to get sound working (for more than a short while,
more on that in a minute) on my ThinkPad T61, which has an Analog
Devices 1984 (AD1984) sound controller. I'm currently running Debian
lenny (2.6.22-3-686 kernel, alsa 1.0.15).

When at first the sound didn't work, I followed the instructions at
that is, to run:

apt-get install module-assistant alsa-source
module-assistant prepare
module-assistant update
module-assistant a-i alsa-source
apt-get remove --purge  alsa-modules-$(uname -r)
invoke-rc.d alsa-utils restart

and then open volume control, go to the "Switch" tab, untick and
retick the speaker tab, unmute PCM, and then press the "volume up"
button on the keyboard a few times (to eliminate the hardware mute, I
believe). To my delight, this worked. However, when I shut down and
later rebooted, nothing worked anymore. Redoing all of these steps
didn't help. Bizarrely, the volume control application no longer even
has the "Switch" tab, so I can't follow part of the steps anymore.
I've googled around, but haven't come across anything that looked like
it could resolve my problem. In some desperation I tried reinstalling
lenny, and even then when I followed the above steps nothing worked.
Any thoughts?

Thank you,
Kyle Barbour

Reply to: