[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "Waiting for root file system" problem

cls@truffula.sj.ca.us skrev:
> [This message has also been posted to linux.debian.user.]
> This is becoming a FAQ.  There is a problem with udev.
> Before udev, there was a strong association between
> device names and devices.  With udev, that association
> is much weaker.
> There's new randomness in how partitions are named
> during boot.
> Debian and other installers have not
> yet worked around this relatively new problem.
> What you're seeing is an effect of that.
> The udeb installer kernel got a different set of
> device names than the installed kernel did, and the
> root file system never appears where the installed
> kernel has been told it would.

Yes, I noticed that I had to call the partition /dev/sda5 to boot with
GRUB, but when booted Debian showed me the partition as /dev/sdc5 !

> The workaround is to use file system labels or UUIDs
> not device names in /etc/fstab and /boot/grub/menu.lst.
> But the Debian 4.0 installer doesn't know that.
> Please read the discussion at
> http://www.debianhelp.org/node/11653

Yes, this worked fine.

> In article <9H9Ej-5g8-29@gated-at.bofh.it>, dave N wrote:
>>   I booted with Knoppix live and there is nothing in /var/log/messages,
>> none of the logs appear to have changed since I last booted 2 days ago.
>> I have not run fsck or anything else on this yet. 
> Apparently Knoppix doesn't use udev.
> Cameron
I tried Knoppix too and found that my partition was called /dev/sda5 and
used that information to edit the GRUB configuration in order to boot.
And was surprised when the partition was called sdc5 after boot, exactly
what was preventing boot in the GRUB configuration!

Thanks for your explanation! I hope this inconsistency will be fixed in
new Debian versions.

Per Tunedal

Reply to: