[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libsane-extras: epson perfection 4490 PHOTO doesn't work on amd64


After making sure that the epson 4490 photo is supported by linux (debian package libsane-extras, epkowa backend) I bought this fine scanner. Works like a charm on ... you know ;)

But on my debian lenny tp61 (Linux haktar #4 SMP Sun Nov 18 17:58:05 CET 2007 x86_64 GNU/Linux) with 64 bit linux, I can't get the scanner to work. I followed the instructions in /usr/share/doc/libsane-extras/README.Debian, added myself to the scanner group and tried scanimage -L, but the scanner didn't appear.

lsusb shows the scanner:

markus@haktar:/usr/lib$ lsusb | grep -i epson
Bus 002 Device 003: ID 04b8:0119 Seiko Epson Corp. Perfection 4490 Photo

lshal shows something about the scanner, too, mainly that the device is located at  /dev/bus/usb/002/003

I straced scanimage but didn't find anything special. Maybe I overlook something. All I see is that the firmware, located in /usr/share/iscan/esfw54.bin isn't touched. Hmm....

I tried installing the packages from http://www.avasys.jp/english/linux_e/dl_scan.html without success. I tried to compile the sources, but the frontend will compile only for IA32.

As you can imagine, google didn't help me, neither. So I am out of ideas and have to double boot for the first time since almost 4 years. Have to get used to windows again :(

I hope that you can help me

Markus Grunwald

Registered Linux User Nr 101577          gpg/pgp fingerprint: 7E01F5FE15CEDD0A
http://counter.li.org                    (gpg --recv-keys 7E01F5FE15CEDD0A)
                                         icq 314331831

Reply to: