[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wifi network connection

On 12/26/07, Mihira Fernando <mihiratheace@gmail.com> wrote:
> On Tue December 25 2007, hce wrote:
> >
> > auto lo
> > iface lo inet loopback
> >
> > # The primary network interface
> > allow-hotplug eth1
> > iface eth1 inet static
> >         address
> >         netmask
> >         network
> >
> > Thank you.
> >
> > Jim
> You have no lines defining your ppp connection ? no matter,
> Remove the up iptables line from /etc/network/interfaces and after the ppp is
> up try running it from the command line to test if NAT is working.

Yes, I run the ppp manually. I did run iptable manually, but did not
seems anything added to the list?

~$ sudo /sbin/iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

~$ sudo /sbin/iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

> the ip forwarding is still enabled right ?

Yes,  I added net.ipv4.conf.default.forwarding=1 in /etc/sysctl.conf

I also tried ifconfig eth1 down and run eth1 by udhcpc, but failed.

$ sudo /sbin/udhcpc -i eth1
udhcpc (v0.9.9-pre) started
Sending discover...
Sending discover...
Sending discover...
Lease failed:

~$ cat /etc/resolv.conf

Did that mean? Why ISP dhcp server did not respose? If that does not
work on my laptop, the wifi router won't get it work either?

Thank you.


Reply to: