[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installer stops (freezes) when scanning hardware


I am currently using Mandriva on this machine. I have tried installing 
Debian on another partition and eventually stop using Mandriva.

This machine is a desktop computer (7VT600P-RZ(-C) mainboard with VIA 
KT600 chipset). I think I have only mainstream hardware (this is no 
laptop!), yet I always have had some problems with it with different 
versions of different distros. 

And right now, I can't install Debian (etch 4.0r1), although I have 
successfully installed Debian on my secondary (older) computer. 

Symptoms with Mandriva: 

1) I managed to install it, but I had to disable harddrake (hardware 
scanning) at bootup because the bootup sequence would freeze 

2) I don't have problems with KDE applications, but with apps such as 
firefox, the gimp and the Mandriva Control Center (MCC) I always 
experience some problems that seem hardware related: MCC never works 
(maybe it scans hardware when we start it), and every morning, the 
*first* time I have to open the "save file as" dialog in firefox or 
gimp, the dialog and the whole app would freeze for a whole 10 
minutes! (when I need to save a file with gimp, I usually open the 
dialog box, go back to konqueror for browsing, then come back later 
when the app is unfrozen). But then, the second time works as it 
This seems to point to a problem with loading some IDE module / 
hardware access problem... I don't know.

3) Most of the time, the system does not shut down completely cleanly: 
at the end of the kernel shutdown sequence, there are some messages 
about being unable to unmount /usr and /home because the resources 
are busy, yet I have never found the stray application that causes 

I am not completely sure that the above symptoms are relevant to the 
Debian install problem, but I include them in case they are...

Symptoms with the Debian installer: 

I have tried several times, and the installer freezes for 5~10 minutes 
*several times* during the install sequence, when checking for the 
hardware. The F4 windown shows something either like:
"hw-detect.hotplug: detected hotpluggable network interface eth0"
or like:
"missing modules ide-mod, id-probe-mod" etc. (I searched the web, but 
the conclusion seems to be that this is not actually tremendously 

Then each time it asks me about entering some data related about 
pcmcia hardware (I enter nothing: as far as I could gather by 
searching the web, I don't need to).

Then at the stage of looking for the partitions, the installer freezes 
one more time, and this time for good (I gave up waiting after 1 


What might cause this? (that's the main question, isn't it?) 

What options can I try when starting the install?
I usually type "install expertgui". What Do I type instead?

What information should I provide that might be relevant, useful? 

Thank you very much for your assistance.

http://minguo.info/ better election methods
http://minguo.info/usa/ the USA FA/DP
Free Association with Delegable Proxy: an internet experiment in 

Reply to: