[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: metacity2.14.5 under etch: keyboard lockup when opening a window

Raj Kiran Grandhi wrote:

I use gnome+metacity in etch.

I am experiencing random lockups of the display since a few hours. Opening a window seems to trigger this. So far it has happened when launching gvim, iceweasel and gnome-terminal (not everytime). What happens in such cases is that the newly opened window is left without the window-manger's borders. Keyboard locks up. Mouse responds to motion, but mouse-clicks do not work. I am able to ssh from a remote machine and kill metacity which seems to bring everything back to normal.

Upgrading metacity to 2.18.5 (testing) appears to have fixed the problem. There has not been any lockup since then.

I never managed to figure out what went wrong though.

There does not seem to be any bug filed against metacity at bugs.debian.org, so I am not sure if it related to metacity.

The only change I have made to the system today is to upgrade icedove to the testing release and install qemu.

Has anybody experienced a similar problem? Is there something I might have done that is causing this?

Raj Kiran

PS: Recent packages in last 2 days as reported by dpkg-www

| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                           Version
ii  bochsbios                      2.3-2etch1
ii  cramfsprogs                    1.1-6
ii  dash                           0.5.3-7
ii  debmirror                      20060907.1
rc  glabels                        2.1.3-1
ii  gtk2-engines-pixbuf            2.12.1-1
ii  icedove              
ii  icedove-gnome-support
ii  iceweasel            
ii  iceweasel-gnome-support
ii  initrd-tools         
ii  libcupsys2                     1.3.2-1
ii  libgtk2.0-0                    2.12.1-1
ii  libgtk2.0-common               2.12.1-1
ii  libgtk2.0-dev                  2.12.1-1
ii  libhunspell-1.1-0              1.1.9-1
ii  libkrb53                       1.6.dfsg.3~beta1-2
ii  libwxbase2.6-0       
ii  libwxgtk2.6-0        
ii  libxdamage-dev                 1.1.1-3
ii  libxdamage1                    1.1.1-3
ii  openhackware                   0.4.1-2
rc  openoffice.org-base            2.0.4.dfsg.2-7etch1
rc  openoffice.org-calc            2.0.4.dfsg.2-7etch1
rc  openoffice.org-common          2.0.4.dfsg.2-7etch1
rc  openoffice.org-core            2.0.4.dfsg.2-7etch1
rc  openoffice.org-draw            2.0.4.dfsg.2-7etch1
rc  openoffice.org-gcj             2.0.4.dfsg.2-7etch1
rc  openoffice.org-impress         2.0.4.dfsg.2-7etch1
rc  openoffice.org-math            2.0.4.dfsg.2-7etch1
rc  openoffice.org-thesaurus-en-us 2.0.4~rc1-3
rc  openoffice.org-writer          2.0.4.dfsg.2-7etch1
ii  proll                          18-2
ii  python-wxgtk2.6      
ii  qemu                           0.8.2-4etch1
ii  systemimager-doc               3.6.3dfsg1-3
ii  vgabios                        0.6a-1
ii  x11proto-damage-dev            1.1.0-2

38 packages

Reply to: