[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


I have an HP Deskjet printer which I have set up using CUPS.  It has
always functioned fine, and I can use lp to print without any problems,
and openoffice, browsers and such work just fine.  However, I use Emacs
and would like to be able to print from within that app, and it uses
lpr, which I have never installed.  I had wondered if that would cause
problems or have conflicts, but I was able to install it with aptitude
seemingly without error.  But, even though everything seemed okay, when
I tried using lpr for printing it did not work.

Initially it would simply retort with "lpr: lp: unknown printer."  I
"seemed" to fix that by setting the variable PRINTER to my printer.
However, that just made it fail silently.  When I looked at the status
of the printer with "lpc status" it said that the jobs were queued, but
that it was waiting for my computer to "come up."  I had no idea what
this was about, as lpd was running and lpr seemed to be taking jobs.

So, what I am wondering is if it is the CUPS way I have been doing
things that has caused the problems, and if so can that be worked
around?  It would seem that CUPS cannot easily be uninstalled on my
system as so much depends on it.  Could my problem be that lprng is not
installed?  This also cannot be fixed easily as it conflicts with CUPS.
If nothing else, maybe somebody knows how to convince emacs to print
without using lpr?

Many thanks for any possible suggestions which anyone can make.


Reply to: