[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Samba + external drives

Ron Johnson wrote:
What if you FTP the file from the OSX box to the firewire drive on
the external drive?

That might narrow down the problem.

Right, I just finished doing some tests. Via NFS and FTP, to the external disc, the same thing happens. The copy runs fine (I was copying a 3.9GB ISO) for a random amount of time - shortest now was 300MB, longest was just under 3GB - and then the disc seem to get unplugged.

Then, I repeated the tests, with samba, NFS and ftp, copying the same ISO to my home directory on the notebook, and this worked without a problem.

I copied the file from the notebook's drive to the external drive - no problem.

Then I tried the following. I ftp-ed to localhost, and did a "put file.iso" to the external drive. This worked 100% I did similar tests with nfs and smb, connecting to localhost and copying the file via the smb/nfs clients - al worked fine.

I also did at least one failed and one successful each using the notebook's wireless instead of wired network, to rule out network hardware, and repeated all the tests from my second notebook (which runs Debian too).

So it's just a mix of network and network copy that seems to cause problems.

I hope that's better :-) Any ideas?

Reply to: