[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Samba + external drives

Hi guys,

I have a strange problem. I use an external IDE/Firewire enclosure on my notebook. This works 100%, is solid as a rock and performs very very well. It works with USB2 too, reliably, just slower.

I have a Mac Mini at home, so I have some samba shares on the external drive. The Mac can acess them fine (OS X 10.4), but when I copy large a file from the Mac to one of the shares on the external drive, it copies a bit and then fails saying something to the effect that the share is not accessible. Looking back at the notebook, syslog gives me the kind of errors you get when unplugging a disc without unmounting it. So my first thought was that either the disc or the enclosure was going bad.

So I ran an fsck on the disc, which came out fine. Copying huge files to it directly from the notebook works fine as well. So it seems to be fine.

Then I remembered I had a similar problem at a client copying from Windows to a samba server on an external (USB2) drive. Different machines, different drives, different distro (SUSE 9.2 or 10.0 at the time). I have since tried various distros on my notebook (extra partition), and I always get the same result, so it seems to be a persisten samba issue.

Has anyone else seen this?


Reply to: