Re: libc6 with support for old kernels
On Tuesday 07 August 2007 14:36, Ph. Marek wrote:
> Hello everybody,
> I'd like to ask for some help.
> I have some machines running an old kernel (2.4.25, from Suse7.3). Now I'd
> like to get some newer software running on them, *without* re-installing
> the whole system.
> (That would be gnuplot, graphviz, subversion, fsvs, and some others).
> About a year ago I could take a debian-installation, take the needed
> files, and put them into a chroot on the old machines, and it worked.
> Without any problem.
> I wanted to do that again, with the current versions; but now I get an
> error message "Kernel too old" (from ld-linux.so AFAIK).
> [ I tried to use the sarge-packages; while the packages work on
> 2.4.25, they are really old versions, and unuseable. Eg. fsvs needs at
> least subversion 1.2, while sarge has only 1.1.4.
> backports.org has subversion 1.4.1 for sarge, but no libsvn0-dev. ]
> Is there an compiled libc6 that has support for older kernels, too, or
> some easy way to recompile it?
> I'd like to use the normal debian-packages, as they're updated
> regularly -- the best solution for me would be to pin libc6 to some
> version or repository, keeping support for the old 2.4, too.
> Help? Any other ideas?
> Thank you for all answers.
> [Please keep me CCed.]
Etch (stable) still boots the 2.4.27 kernel ok, but Lenny (testing) after some
updates a bit back, now gives me a "kernel to old" message.
anyway, looking at synaptic on Etch, Subversion is 1.4.2dfsg1-2, libsvn-dev is
1.4.2dfsg1-2, and libc6 is 2.3.6.ds1-13.
I don't know if that's any help.
btw. All my Debian installs, Sarge, Etch, and Lenny, started off as Woody
3.0r2, and is why I still have the 2.4.27 kernel installed on all of them.